Willkommen, Gast
Angemeldet bleiben:

THEMA:

[gelöst]Probleme mit SEO 04 Jul 2007 07:55 #7965

  • Autor
  • Anonymous
  • Besucher
  • Besucher
Hallo,
ich habe Probleme mit der SEO Funktion von Joomla.
Immer wenn ich diese aktiviere erhalte ich "Fehler 404", sobald ich einen Link auf einer Seite anklicke.

mod_rewrite ist installiert, aktiviert und eingebunden.
.htacess existiert

Den Fehler erhalte ich, ob ich SEO von Joomla verwende oder die Komponente von Artio.

Mir ist Dank mouseover und Statusleiste aufgefallen, dass die Links wunderbar in Suchmaschinenfreundliche URLs umgewandelt werden. Klicke ich einen Link an, wird diese URL so (Suchmaschinenfreundlich) in die Adresszeile geschrieben.

Die Seite ist aus dem Internet leider noch nicht zu erreichen, Sie wird erst nach außen freigeschalten werden, wenn das Projekt so gut wie abgeschlossen ist.

Deswegen eine kurze Beschreibung der Struktur.
subdomain.domain.com verweißt auf mein root und das Managementtool des Servers.
Joomla läuft aber unter:
subdomain.domain.com/exjoombyte/index.php, weswegen ich den Ordner unter RewriteBase eingetragen hatte.

Ich habe jetzt an die 12 Stunden land verschiedene .htacess und interne Konfigurationen getestet, den Server auf verschiedene Arten manipuliert, Foren abgegrast und im Netz recherchiert, aber ich komme nicht weiter. Hat irgendjemand Ideen, Hinweise oder einen Tipp für mich parat?

Danke
Stephan
Systembeschreibung:
  • Version: Joomla 1.0.12
  • Server: Linux
  • Webserver: apache2
  • Komponente: ARTIO JoomSEF v1.5.1

.htacess
##
# @version $Id: htaccess.txt 5973 2006-12-11 01:26:33Z robs $
# @package Joomla
# @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


#####################################################
#  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
#
# Only use one of the two SEF sections that follow.  Lines that can be uncommented
# (and thus used) have only one #.  Lines with two #'s should not be uncommented
# In the section that you don't use, all lines should start with #
#
# For Standard SEF, use the standard SEF section.  You can comment out
# all of the RewriteCond lines and reduce your server's load if you
# don't have directories in your root named 'component' or 'content'
#
# If you are using a 3rd Party SEF or the Core SEF solution
# uncomment all of the lines in the '3rd Party or Core SEF' section
#
#####################################################

#####  SOLVING PROBLEMS WITH COMPONENT URL's that don't work #####
# SPECIAL NOTE FOR SMF USERS WHEN SMF IS INTEGRATED AND BRIDGED
# OR ANY SITUATION WHERE A COMPONENT's URL's AREN't WORKING
#
# In both the 'Standard SEF', and '3rd Party or Core SEF' sections the line:
# RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
# May need to be uncommented.  If you are running your Joomla!/Mambo from
# a subdirectory the name of the subdirectory will need to be inserted into this
# line.  For example, if your Joomla!/Mambo is in a subdirectory called '/test/',
# change this:
# RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
# to this:
# RewriteCond %{REQUEST_URI} ^(/test/component/option,com) [NC,OR] ##optional - see notes##
#
#####################################################
<Files .htaccess>
order deny,allow
deny from all
</Files> 

##  Can be commented out if causes errors, see notes above.
Options FollowSymLinks

#
#  mod_rewrite in use

RewriteEngine On


#  Uncomment following line if your webserver's URL
#  is not directly related to physical file paths.
#  Update Your Joomla!/MamboDirectory (just / for root)

RewriteBase /exjoombyte


########## Begin - Joomla! core SEF Section
############# Use this section if using ONLY Joomla! core SEF
## ALL (RewriteCond) lines in this section are only required if you actually
## have directories named 'content' or 'component' on your server
## If you do not have directories with these names, comment them out.
#
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_URI} ^(/exjoombyte/component/option,com) &#91;NC,OR&#93; 		##optional - see notes##
#RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/&#91;^.&#93;*)$  &#91;NC&#93;
#RewriteRule ^(content/|component/) index.php
#
########## End - Joomla! core SEF Section



########## Begin - 3rd Party SEF Section
############# Use this section if you are using a 3rd party (Non Joomla! core) SEF extension - e.g. OpenSEF, 404_SEF, 404SEFx, SEF Advance, etc
#
RewriteCond %{REQUEST_URI} ^(/exjoombyte/component/option,com) &#91;NC,OR&#93; 		##optional - see notes##
RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/&#91;^.&#93;*)$  &#91;NC&#93;
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) index.php
#
########## End - 3rd Party SEF Section



########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_&#91;a-zA-Z_&#93;{1,21}(=|\%3D) &#91;OR&#93;
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) &#91;OR&#93;
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) &#91;NC,OR&#93;
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\&#91;|\%&#91;0-9A-Z&#93;{0,2}) &#91;OR&#93;
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\&#91;|\%&#91;0-9A-Z&#93;{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php &#91;F,L&#93;
#
########## End - Rewrite rules to block out some common exploits

[size=80:2be6uwmq]Edit: Thema als gelöst Markiert[/size]

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Probleme mit SEO 04 Jul 2007 11:15 #7971

  • sisko1990
  • Besucher
  • Besucher
Hallo "Stephan",
versuche mal aus Deiner htaccess diese Zeile auszukommentieren: "Options FollowSymLinks" also so: "#Options FollowSymLinks"
Der Rest sieht für mich eigentlich ganz gut aus. Auch schon versucht diese Zeile auszukommentieren?: "RewriteCond %{REQUEST_URI} ^(/exjoombyte/component/option,com) [NC,OR]" - Daran kann es nämlich auch liegen

Aber: Ich denke die Zeile mit "FollowSymLinks" ist für die Fehler verantwortlich, versuche erst mal die.

Cu, Jan.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Probleme mit SEO 04 Jul 2007 11:24 #7974

  • Autor
  • Anonymous
  • Besucher
  • Besucher
Danke Jan, aber das war es nicht.
Habe aber gerade eben etwas amüsantes festgestellt.
Deaktiviere ich JoomSEF und behalte SEO aktiviert funktioniert alles. Aktiviere ich JoomSEF oder deinstalliere es geht wieder nichts mehr.
Von daher vermute ich, dass das Problem mit JoomSEF verknüpft ist. Sobald ich das auseinander gepflückt und bereinigt habe werde ich die Lösung gerne weitergeben. Bin da momentan dran.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Probleme mit SEO 04 Jul 2007 11:26 #7975

  • sisko1990
  • Besucher
  • Besucher
Falls es mit JoomSEF nicht geht kannst Du ja auch sh404SEF benutzen. Ist ähnlich wie JoomSEF aufgebaut...

Cu, Jan.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Probleme mit SEO 04 Jul 2007 17:31 #7991

Salü

wie wäre es, die Doku lesen und die .htaccess ändern, wenn du von SEO auf JoonSEF umstellst?
Steht auch in der .htaccess selber drin :o

Überigens, bist du sicher, dass die gepostete .htaccess aktiv ist. Diese würde dir einen 500er Fehler (Server Fehler) geben, denn ein # ist nur am Zeilenanfang erlaubt.

Gruss Hansueli

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Probleme mit SEO 05 Jul 2007 08:12 #8014

  • Autor
  • Anonymous
  • Besucher
  • Besucher
Servus

.htaccess funktioniert.
Wenn man die Artio Doku liest und die darin angegebene .htaccess mit meiner Datei vergleicht wird man feststellen, dass die sich, bis auf minimale Anpassungen, sehr ähnlich sind.

Inzwischen ist die Datei wieder neu konfiguriert und SEO läuft ohne andere Komponente, bis ich diese zum Laufen bringe.

Step by Step.
Wenn ich mal nicht weiter komme frage ich, ansonsten lese ich Dokus und probiere und tüftle. Was ein Grund dafür ist warum ich mich, bis vor kurzem, nach dem Umstellung von Mambo auf Joomla in keinem Forum mehr eingetragen hatte.

Gruß
Stephan

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Probleme mit SEO 12 Jul 2007 15:57 #8111

  • oberon
  • Besucher
  • Besucher
Hallo zusammen

ich empfehle opensef.

oberon

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Probleme mit SEO 12 Jul 2007 16:12 #8117

  • Autor
  • Anonymous
  • Besucher
  • Besucher
Bei openSEF wurde die Entwicklung eingestellt, weil der/die Entwickler nun auf Drupal setzen. Auf deren Webseite gibt es keine Links mehr zu den ehemaligen Mambo/Joomla Sourcen.
Demnach müsste spätestens mit der 1.5er Version openSEF nicht mehr nutzbar sein, wenn nicht jemand anderes dieses Projekt fort führt.
Deswegen scheidet openSEF -für mich zumindest- leider aus.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Probleme mit SEO 12 Jul 2007 16:20 #8119

Stephan schrieb: Bei openSEF wurde die Entwicklung eingestellt, weil der/die Entwickler nun auf Drupal setzen. Auf deren Webseite gibt es keine Links mehr zu den ehemaligen Mambo/Joomla Sourcen.
Demnach müsste spätestens mit der 1.5er Version openSEF nicht mehr nutzbar sein, wenn nicht jemand anderes dieses Projekt fort führt.
Deswegen scheidet openSEF -für mich zumindest- leider aus.


Hallo Stephan,

Das stimmt so nicht ganz....
schau mal hier: --ALTER LINK WURDE ENTFERNT--
und hier: --ALTER LINK WURDE ENTFERNT--

Gruess

Pete

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Probleme mit SEO 12 Jul 2007 16:35 #8121

  • Autor
  • Anonymous
  • Besucher
  • Besucher
Danke Pete, für den Hinweis.
Ich kannte bisher nur die Seite von Xaneon, der/die leider mit Joomla aufgehört hat/haben.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1
  • 2