Willkommen, Gast
Angemeldet bleiben:

THEMA:

localhost geht nicht, aber 127.0.0.1 funzt? wieso? 31 Mär 2009 16:00 #21404

  • Autor
  • kuckuck
  • Besucher
  • Besucher
Hallo zusammen

Und wieder ist ein Neuling im Lande der Greenhorn-Fragen stellt. Hoffe aber, dass jemand doch noch Lust und Zeit hat mir da zu helfen. Thanks anyway.

Also das Problem ist die Eingabe --ALTER LINK WURDE ENTFERNT-- . Da bringt mir der Explorer die simple Meldung
Die Webseite kann nicht angezeigt werden.

Bei der Eingabe --ALTER LINK WURDE ENTFERNT-- reagiert er dann ganz freundlich und bringt mir die Startseite.

Warum funzt der Begriff "localhost" bei mir nicht? Und wie könnte man das allenfalls beheben?

Installation von XAMPP 1.7.0 und de-DE_joomla_lang_full.1.5.10v1 wurde gemäss diversen Anleitungen (verglichen) durchgeführt.
ich habe eine Vista Home Premium Edition und der Windows Explorer mit Version 7.0
Avira Antiviernprogramm etc.

Installiert habe ich das ganze im Verzeichnis c:xampp
In der Datei apacheconfhttpd.conf steht auch
DocumentRoot "C:/xampp/htdocs"

tja, da bin ich am Ende des Lateins und auch in keinem Forum was gefunden.

Dann habe ich noch eine Frage zu den Updates
Bei der Seite wo ich die joomla Installation geholt habe gibt es massenweise Updates.
Eine davon heisst
Joomla_1.5.9_to_1.5.10-Stable-Patch_Package

ist die nötig?
wenn ja, wenn ich die entzippe und das Verzeichnis xampp/htdocs/joomla angebe, dann überschreibt er mir doch wohl alle Verzeichnisse. Und er hat teilweise in der Update-Version weniger Dateien drin???
Wie müsste ich da vorgehen? Einfach ersetzen?

Freu mich auf Euer Feedback

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: localhost geht nicht, aber 127.0.0.1 funzt? wieso? 31 Mär 2009 16:42 #21405

  • DietmarH
  • Besucher
  • Besucher
Unter WinXP wird dem System in der Datei X:\WINDOWS\system32\drivers\etc\hosts mitgeteilt, daß 127.0.0.1 den Klartextnamen localhost hat. Ohne diesen Eintrag kann das Netzwerk den Namen nicht auflösen. Unter Vista gibt es sicher eine ähnliche Datei, aber ich habe keine Ahnung, wo die liegt.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: localhost geht nicht, aber 127.0.0.1 funzt? wieso? 01 Apr 2009 13:54 #21409

  • Autor
  • kuckuck
  • Besucher
  • Besucher

DietmarH schrieb: Unter WinXP wird dem System in der Datei X:\WINDOWS\system32\drivers\etc\hosts mitgeteilt, daß 127.0.0.1 den Klartextnamen localhost hat. Ohne diesen Eintrag kann das Netzwerk den Namen nicht auflösen. Unter Vista gibt es sicher eine ähnliche Datei, aber ich habe keine Ahnung, wo die liegt.


Danke mal für den Hinweis.
ich habe die Datei genau dort gefunden (Laufwerk c:)

die hat aber den untenstehenden Inhalt:
Ich habe auch versucht das anzupassen mit einer zusätzlichen Linie
127.0.0.1 localhost
genützt hat es wenig
:-\ \

# Copyright (c) 1993-2006 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host


::1 localhost

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: localhost geht nicht, aber 127.0.0.1 funzt? wieso? 01 Apr 2009 15:48 #21411

Jaja... weiss schon warum ich das sch*** Vista raschmoeglichst geloescht hab...

Nun, das Hosts File ist seit Vista ein System File. Du musst Dir fuer diese Datei erst volle Kontrolle geben:

Aber erst muessen wir auch noch das Command Prompt als Administrator ausfuehren:

1.) Rechtsklick auf Command Promt und waehle 'Als Administrator ausfuehren'

2.) Im Command Prompt eingeben:
takeown /f c:\windows\system32\drivers\etc\hosts

3.)Im Command Prompt eingeben:
icacls c:\windows\system32\drivers\etc\hosts /grant DEINBENUTZERNAME:f

(Bitte BENUTZERNAME mit Deinem Windows Benutzernamen ersetzen)

4.) Nun solltest das hosts file mit dem Notepad bearbeiten koennen und die folgende Zeile hinzufuegen und speichern:
127.0.0.1 localhost

Nun noch schauen ob das Vista nicht wieder ein Dateiendung .txt hinzugefuegt hat und gut sollte sein...

Sollte moeglicherweise auch gehen, wenn Du das Notepad als Admin ausfuehrst und das Hostsfile oeffnet...

Oder auch wenn Du wieder XP installierst.... ;-)
Es Griessli
Peter

Joomla US Webhosting / Mein privates Weblog

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: localhost geht nicht, aber 127.0.0.1 funzt? wieso? 06 Apr 2009 15:16 #21449

  • Autor
  • kuckuck
  • Besucher
  • Besucher
Super. nach einigen kleinen "Rechtsschreibefehler" von mir bezüglich localhost etc. (ohne Doppelpunkte vor der IP Adresse..) hat das super funktioniert. Musste mich nicht mal als Adminstrator anmelden (bin das wohl als einziger Nutzer schon).
Aber der Tipp für den Administrator merke ich mir auf jeden Fall, denn ich arbeite auch noch oft an Gemeinschafts-PC's etc.
Ich verneige mich vor Eurem Wissen und vor Eurer Hilfsbereitschaft
G_O_O_D O_O_D


Rastamate schrieb: Jaja... weiss schon warum ich das sch*** Vista raschmoeglichst geloescht hab...

Nun, das Hosts File ist seit Vista ein System File. Du musst Dir fuer diese Datei erst volle Kontrolle geben:

Aber erst muessen wir auch noch das Command Prompt als Administrator ausfuehren:

1.) Rechtsklick auf Command Promt und waehle 'Als Administrator ausfuehren'

2.) Im Command Prompt eingeben:
takeown /f c:\windows\system32\drivers\etc\hosts

3.)Im Command Prompt eingeben:
icacls c:\windows\system32\drivers\etc\hosts /grant DEINBENUTZERNAME:f

(Bitte BENUTZERNAME mit Deinem Windows Benutzernamen ersetzen)

4.) Nun solltest das hosts file mit dem Notepad bearbeiten koennen und die folgende Zeile hinzufuegen und speichern:
127.0.0.1 localhost

Nun noch schauen ob das Vista nicht wieder ein Dateiendung .txt hinzugefuegt hat und gut sollte sein...

Sollte moeglicherweise auch gehen, wenn Du das Notepad als Admin ausfuehrst und das Hostsfile oeffnet...

Oder auch wenn Du wieder XP installierst.... ;-)

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1