Willkommen, Gast
Angemeldet bleiben:

THEMA:

Fehlermeldung auf Site 31 Mai 2013 17:52 #36974

  • sguggers Avatar Autor
  • sgugger
Hallo zusammen

Habe auf der Site www.gugge-akademiker.ch festgestellt das die Newskomponenete "Fanews" plötzlich eine Fehler aufweist.

Diesen hier:

Deprecated: Assigning the return value of new by reference is deprecated in /home/httpd/vhosts/gugge-akademiker.ch/httpdocs/modules/mod_fanews/mod_fanews.php on line 29

Habe auch schon versucht unter "Konfiguration" -> "Server" -> Fehler auf "Keine" oder "Standard" und "Einfach" zu setzten jedoch ohne Erfolg.

Hoffe jemand kann mir helfen.

Grüsse

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Fehlermeldung auf Site 31 Mai 2013 23:55 #36978

Wird wohl nicht plötzlich aus dem nichts gekommen sein. ;)
Ich vermute mal dein Hoster hat evt. ein PHP Update getätigt.

Nimm doch mal die mod_fanews.php genauer unter die Lupe.
Sonst poste mal die Zeil 29.

Gruss Ray
Don’t take life as hard it is, because you are the one who can change it.
So, if something is impossible, use your imagination.

Ray L.
Folgende Benutzer bedankten sich: sgugger

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Fehlermeldung auf Site 01 Jun 2013 08:13 #36979

  • sguggers Avatar Autor
  • sgugger
Werde mich so rasch wie möglich melden. Bin gerade auf der Arbeit.

Danke im voraus!!

Gruss Serge

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Fehlermeldung auf Site 01 Jun 2013 14:19 #36982

  • sguggers Avatar Autor
  • sgugger
Linie 29 ist markiert.

<?php
/**
* Faboba News System
* @package Joomla!
* @Copyright (C) 2010 Faboba.com
* @ All rights reserved
* @ Joomla! is Free Software
* @ Released under GNU/GPL License : www.gnu.org/copyleft/gpl.html
* @version $Revision: 1.0 $
**/

/**
access restriction
**/
defined('_JEXEC') or die('Restricted access');

/**
Loading helper class
**/

//
require_once (dirname(__FILE__).DS.'helper.php');
//
if(!class_exists('FaNewsLayout'))
{
require_once(JModuleHelper::getLayoutPath('mod_fanews', 'layout.parts'));
}
//
$helper =& new FaNewsHelper();
//
$helper->init();
$helper->validateVariables($params);
$helper->getDatas();
$helper->renderLayout();

?>

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Fehlermeldung auf Site 01 Jun 2013 16:47 #36983

Manchmal können kleine Dinge grosses bewirken.
Versuch einfach mal das & zu löschen und Schau mal was passiert

$helper= new FaNewsHelper();
Don’t take life as hard it is, because you are the one who can change it.
So, if something is impossible, use your imagination.

Ray L.
Folgende Benutzer bedankten sich: sgugger

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Fehlermeldung auf Site 03 Jun 2013 09:46 #36992

  • sguggers Avatar Autor
  • sgugger
Hatte keinen Erfolg mit dem $ löschen.
Ich habe eine andere Site mit dem gleichen Modul dort habe ich keine Probleme!
Gleicher Server

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Fehlermeldung auf Site 03 Jun 2013 09:49 #36993

  • sguggers Avatar Autor
  • sgugger
Hat doch geklappt!!!!! ;D

Vielen Dank, musste ein zweites mal aktualisieren! ;)

Was macht dieses Dollar Zeichen genau?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Fehlermeldung auf Site 06 Jun 2013 21:53 #37035

Hast du das Dollarzeichen gelöscht?
Das Dollarzeichen sagt sozusagen, dass dies eine Variable ist.
Versuch doch noch die Variante, nur (&) Zeich zu löschen und lass das ($) stehen.
Sollte so auch funktionieren.
Dieses (&) Zeichen war für die früheren PHP Version nötig, damit es wusste, dass dies eine Rederenz ist.
Dies ist ab PHP 5 nicht mehr nötig.
Don’t take life as hard it is, because you are the one who can change it.
So, if something is impossible, use your imagination.

Ray L.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1