Willkommen, Gast
Angemeldet bleiben:

THEMA:

Vertikaler und horizontaler Abstand klappt nicht 19 Mär 2009 10:41 #21204

  • eyJeys Avatar Autor
  • eyJey
Hallo,

der vertikale und horizontale Abstand bei Bildern im Beitrag klappt im FF nicht. Im IE jedoch schon.

Hat einer schon mal eine ähnliche Situation gehabt und kann mir hilfreiche Tips geben? Weiß nicht, was das sein kann.

Gruß

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Vertikaler und horizontaler Abstand klappt nicht 19 Mär 2009 14:06 #21209

Hallo eyJey,

Ein Link zur Seite und ein etwas detaillierter Beschrieb des Problems wuerde schon sehr helfen....

Zudem hat Deine Frage bisher noch nicht mal was mit Joomla zu tun und bin gerade am ueberlegen diesen Faden zu verschieben.
Es Griessli
Peter

Joomla US Webhosting / Mein privates Weblog

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Vertikaler und horizontaler Abstand klappt nicht 19 Mär 2009 14:21 #21214

  • DietmarHs Avatar
  • DietmarH
Wenn man die Abstände richtig definiert, klappt das auch.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Vertikaler und horizontaler Abstand klappt nicht 19 Mär 2009 18:28 #21220

  • eyJeys Avatar Autor
  • eyJey
Tja... also wenn ich Joomla verwende, dann muss es ja irgendwas mit Joomla zu tun haben ??? ?

Ok. Dann hier mal ein Beispiel. Wenn ihr euch mal diese Seite:

--ALTER LINK WURDE ENTFERNT--

mit dem IE und FF anschaut, dann seht ihr, dass der Abstand vom Bild zum Text im IE da ist, und im FF nicht. Eingestellt ist ein "Space" von 10px.

Das ist das Problem.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Vertikaler und horizontaler Abstand klappt nicht 19 Mär 2009 18:34 #21221

Werd doch noch etwas genauer, bitte!
Welcher Abstand, wo?

Meines erachtens an sieht die Seite in IE 7 und FF 3.0.7 absolut gleich aus.
Es Griessli
Peter

Joomla US Webhosting / Mein privates Weblog

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Vertikaler und horizontaler Abstand klappt nicht 19 Mär 2009 19:20 #21222

Und nur so zur Kenntnis, dieses Thema wird auch an einem anderen Ort besprochen:

--ALTER LINK WURDE ENTFERNT--
Es Griessli
Peter

Joomla US Webhosting / Mein privates Weblog

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Vertikaler und horizontaler Abstand klappt nicht 19 Mär 2009 19:40 #21223

  • eyJeys Avatar Autor
  • eyJey

Werd doch noch etwas genauer, bitte!
Welcher Abstand, wo?

Meines erachtens an sieht die Seite in IE 7 und FF 3.0.7 absolut gleich aus.


Das macht mich aber jetzt stutzig. Sieht es nur bei mir so aus? Hier mal ein Vergleichsbild.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Vertikaler und horizontaler Abstand klappt nicht 19 Mär 2009 19:44 #21224

Ah stimmt.. hast recht...

Wollte auch nur, dass Du das Problem etwas genauer beschreibst...

Nun.. lass uns das mal analysieren...
Es Griessli
Peter

Joomla US Webhosting / Mein privates Weblog

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Vertikaler und horizontaler Abstand klappt nicht 19 Mär 2009 19:45 #21225

Du hast im template.css auf Zeile 74

ein margin: 0; in der img {} Anweisung.

Nimm das margin: 0; raus und es funktioniert auch mit dem FF...
Es Griessli
Peter

Joomla US Webhosting / Mein privates Weblog

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Vertikaler und horizontaler Abstand klappt nicht 19 Mär 2009 20:02 #21226

  • 69waterproofs Avatar
  • 69waterproof
hspace und vspace wird in Zukunft wohl abgeschafft (bei W3C als depriciated markiert). Arbeite statt dessen mit padding oder margin:
margin-right: 10px;

Damit sollte es in allen Browsern klappen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1
  • 2